dotfiles/nix/configuration.nix
2024-08-29 18:25:03 +02:00

139 lines
3.3 KiB
Nix
Executable file

{ config, pkgs, ... }:
{
imports =
[
# Include the results of the hardware scan.
./hardware-configuration.nix
# system stuff
./system/display.nix
./system/sound.nix
./system/essentials.nix
./system/shell.nix
./system/remap.nix
./system/ssd.nix
# rice and other usefull apps
./desktop.nix
# developing tools
./dev.nix
# music
./apps/music.nix
# gayming
./gaming.nix
# communcations apps
./apps/communication.nix
# password manager
./apps/keepassxc.nix
# productivity apps
./apps/prod.nix
# enabling sandboxing and other security measures
./system/security.nix
# file sync
./apps/syncthing.nix
# libreoffice
./apps/office.nix
# node xporter
#./configs/prometheus.nix
./configs/neofetch.nix
./configs/logseq.nix
./configs/i3.nix
./configs/rofi.nix
./configs/picom.nix
./configs/polybar.nix
./configs/btop.nix
./configs/ollama.nix
./configs/vscode.nix
./configs/gpu-screen-recorder.nix
./configs/firefox.nix
./configs/waydroid.nix
#./configs/builders.nix
./configs/element.nix
./configs/nvim.nix
./configs/node_exporter.nix
# terminal
#./configs/st.nix # too minimal, most things dont work without a million tweaks
#./configs/kitty.nix # uses their own stupid xterm extension...
./configs/alacritty.nix # just perfect, tho too much gpu usage
# apps
./apps/graphics.nix
# other
./configs/firewall.nix
];
# adding nur
nixpkgs.config.packageOverrides = pkgs: {
nur = import (builtins.fetchTarball "https://github.com/nix-community/NUR/archive/master.tar.gz") {
inherit pkgs;
};
};
# adding flake support
nix.settings.experimental-features = [ "nix-command" "flakes" ];
home-manager.users.grape = { ... }: {
home.stateVersion = "24.05";
};
# Bootloader.
boot.loader.systemd-boot.enable = true;
boot.loader.efi.canTouchEfiVariables = true;
#boot.initrd.luks.devices."luks-f7e86dde-55a5-4306-a7c2-cf2d93c9ee0b".device = "/dev/disk/by-uuid/f7e86dde-55a5-4306-a7c2-cf2d93c9ee0b"; # old dead ssd rip 24.07.28
boot.initrd.luks.devices."luks-da1b2f8c-877a-4c39-8965-a4af625718c".device = "/dev/disk/by-uuid/da1b2f8c-877a-4c39-8965-a4af6a25718c";
networking.hostName = "strix";
# Enable networking
networking.networkmanager.enable = true;
# Set your time zone.
time.timeZone = "Europe/Budapest";
# Select internationalisation properties.
i18n.defaultLocale = "en_US.UTF-8";
i18n.extraLocaleSettings = {
LC_ADDRESS = "hu_HU.UTF-8";
LC_IDENTIFICATION = "hu_HU.UTF-8";
LC_MEASUREMENT = "hu_HU.UTF-8";
LC_MONETARY = "hu_HU.UTF-8";
LC_NAME = "hu_HU.UTF-8";
LC_NUMERIC = "hu_HU.UTF-8";
LC_PAPER = "hu_HU.UTF-8";
LC_TELEPHONE = "hu_HU.UTF-8";
LC_TIME = "hu_HU.UTF-8";
};
users.users.grape = {
isNormalUser = true;
description = "grape";
extraGroups = [ "networkmanager" "wheel" "audio" "docker" ];
};
nixpkgs.config.allowUnfree = true;
nix.settings.auto-optimise-store = true;
system.stateVersion = "24.11";
}