2005
9216cbbf62
added logging to all nginx routes added loki, promtail to scrape nginx logs turned i2pd back on, updated my websites version upgraded all hosts to 24.05 forgejo added bigger limit to upload limit due to docker images privacy frontends: added priviblur libreddit -> redlib added biblioreads ddns-updater, changed credentials but there is a bug with porkbun added penpot brought back anonymousoverflow added readme privacy respecting frontends
20 lines
474 B
Nix
20 lines
474 B
Nix
{ pkgs, config, ... }: {
|
|
|
|
services.inadyn = {
|
|
# TODO wait for fix
|
|
# https://github.com/troglobit/inadyn/issues/483
|
|
enable = false;
|
|
settings.provider.porkbun = {
|
|
checkip-server = "icanhazip.com";
|
|
username = config.age.secrets.porkbun-user.path; # public key
|
|
password = config.age.secrets.porkbun.path; # private key
|
|
#hostname = [
|
|
# "4o1x5.dev"
|
|
# "*.4o1x5.dev"
|
|
#];
|
|
ssl = true;
|
|
ttl = 600;
|
|
};
|
|
};
|
|
}
|