46 lines
983 B
Nix
46 lines
983 B
Nix
{ pkgs, ... }: {
|
|
#
|
|
services.loki = {
|
|
enable = false;
|
|
configuration = {
|
|
auth_enabled = false;
|
|
server = {
|
|
http_listen_port = 3100;
|
|
};
|
|
ingester = {
|
|
lifecycler = {
|
|
address = "0.0.0.0";
|
|
ring = {
|
|
kvstore.store = "inmemory";
|
|
replication_factor = 1;
|
|
};
|
|
};
|
|
chunk_idle_period = "15m";
|
|
};
|
|
schema_config.configs = [
|
|
{
|
|
from = "2020-02-25";
|
|
store = "boltdb";
|
|
object_store = "filesystem";
|
|
schema = "v11";
|
|
index = {
|
|
prefix = "index_";
|
|
period = "24h";
|
|
};
|
|
}
|
|
];
|
|
|
|
storage_config = {
|
|
boltdb.directory = "/tmp/loki/index";
|
|
};
|
|
limits_config = {
|
|
enforce_metric_name = false;
|
|
reject_old_samples = true;
|
|
reject_old_samples_max_age = "500h";
|
|
};
|
|
chunk_store_config.max_look_back_period = "0s";
|
|
|
|
};
|
|
};
|
|
}
|