This repository has been archived on 2024-08-30. You can view files and clone it, but cannot push or open issues or pull requests.
infrastructure/hosts/pink/services/actions-runner.nix
2005 42899d79db 💻 runners:
now pink is a runner for forgejo too
2024-06-12 18:09:08 +02:00

24 lines
625 B
Nix

{ pkgs, config, ... }:
{
services.gitea-actions-runner.instances = {
root = {
enable = true;
url = "https://git.4o1x5.dev";
tokenFile = config.age.secrets.actions-runner.path;
settings = {
container = {
# TODO fix: networking
# instead of using host, create a subnet that cannot contact other server on my network to avoid being haxxed
network = "host";
};
};
labels = [
"ubuntu-latest:docker://gitea/runner-images:ubuntu-latest"
];
name = "${config.networking.hostName}@${config.networking.domain}";
};
};
}