neo2005/config/keymaps.nix

27 lines
472 B
Nix

{ ... }:
{
keymaps = [
{
# Focus file tree
key = "<leader>v";
action = "<cmd>CHADopen --always-focus<cr>";
}
{
# Toggle file tree
key = "<leader>e";
action = "<cmd>CHADopen<cr>";
}
{
# format current document
mode = "n";
key = "<leader>bf";
action = "<cmd>lua require('conform').format()<cr>";
options = {
silent = true;
desc = "Format Buffer";
};
}
];
}