neo2005/config/plugins/lang/csharp.nix
2024-12-19 22:41:52 +01:00

23 lines
327 B
Nix

{ pkgs, ... }:
{
plugins = {
lsp.servers.csharp_ls.enable = true;
conform-nvim.settings = {
formatters_by_ft = {
dotnet = [ "dotnet" ];
};
formatters = {
dotnet = {
command = "${pkgs.dotnet-sdk_8 }/bin/dotnet format";
};
};
};
# TODO lint
};
}