neo2005/config/plugins/lang/nix.nix

37 lines
617 B
Nix

{ pkgs, ... }:
{
plugins = {
nix.enable = true;
hmts.enable = true;
nix-develop.enable = true;
conform-nvim.settings = {
formatters_by_ft = {
nix = [ "nixfmt-rfc-style" ];
};
formatters = {
nixfmt-rfc-style = {
command = "${pkgs.nixfmt-rfc-style}/bin/nixfmt";
};
};
};
lint = {
lintersByFt = {
nix = [ "statix" ];
};
linters = {
statix = {
cmd = "${pkgs.statix}/bin/statix";
};
};
};
};
extraConfigVim = ''
au BufRead,BufNewFile flake.lock setf json
'';
}