neo2005/config/plugins/lang/protobuf.nix

23 lines
347 B
Nix

{ pkgs, ... }:
{
# Enable language server for protbuf files (.proto)
plugins = {
lsp.servers.protols = {
enable = true;
};
lint = {
lintersByFt = {
protobuf = [ "protobuf" ];
};
linters = {
protobuf = {
cmd = "${pkgs.protolint}/bin/protolint";
};
};
};
};
}