neo2005/config/plugins/lang/sh.nix

18 lines
282 B
Nix

{ pkgs, ... }:
{
plugins = {
conform-nvim.settings = {
formatters_by_ft = {
sh = [ "shfmt" ];
};
formatters = {
shfmt = {
command = "${pkgs.shfmt}/bin/shfmt";
};
};
};
lsp.servers.bashls.enable = true;
};
}