Barna Máté
09ebce4613
- added code companion - added neogen for annotations - remapped trouble keybinds - some other stuff idk
29 lines
491 B
Nix
29 lines
491 B
Nix
{ pkgs, ... }: {
|
|
plugins.trouble = {
|
|
enable = true;
|
|
settings.auto_close = true;
|
|
};
|
|
|
|
keymaps = [
|
|
{
|
|
mode = "n";
|
|
key = "<leader>xx";
|
|
action = "<cmd>Trouble diagnostics<cr>";
|
|
options = {
|
|
silent = true;
|
|
desc = "Show trouble diagnostics";
|
|
};
|
|
}
|
|
{
|
|
mode = "n";
|
|
key = "<leader>xt";
|
|
action = "<cmd>Trouble TODO's<cr>";
|
|
options = {
|
|
silent = true;
|
|
desc = "Show TODOs";
|
|
};
|
|
}
|
|
|
|
];
|
|
}
|