neorg/config/default.nix

127 lines
2.4 KiB
Nix

{ pkgs, ... }:
{
colorscheme = "shades_of_purple";
opts = {
number = true;
relativenumber = true;
};
keymaps = [
{
# Focus file tree
key = "<leader>v";
action = "<cmd>CHADopen --always-focus<cr>";
}
{
# Toggle file tree
key = "<leader>e";
action = "<cmd>CHADopen<cr>";
}
];
# Set <Space> as leader
globals.mapleader = " ";
globals.maplocalleader = ",";
extraPlugins = with pkgs; [
# TODO add from flake.nix
{
plugin = pkgs.vimUtils.buildVimPlugin {
pname = "shades_of_purple";
version = "1.0.2"; # dummy version
doCheck = false;
src = pkgs.fetchFromGitea {
domain = "git.4o1x5.dev";
owner = "4o1x5";
repo = "shades-of-purple-nvim";
rev = "2db251e8efa16e4cb7574092686a941448252fa7";
hash = "sha256-DsswRJgpv04pSunRlAFTJ0CmwLg+oZwxdsX1BkAe6V0=";
};
};
}
vimPlugins.lush-nvim
];
# enable neogen
plugins.neorg = {
enable = true;
telescopeIntegration.enable = true;
settings = {
load = {
"core.concealer" = {
config = {
icon_preset = "diamond";
};
};
"core.defaults" = {
__empty = null;
};
"core.integrations.telescope" = {
__empty = null;
};
"core.dirman" = {
config = {
workspaces = {
home = "~/neorg";
};
};
};
};
};
};
plugins.image = {
enable = true;
integrations.neorg.enabled = true;
};
plugins.telescope = {
enable = true;
extensions = {
fzf-native.enable = true;
undo.enable = true;
ui-select = {
settings = {
specific_opts = {
codeactions = true;
};
};
};
};
keymaps = {
"<leader><space>" = {
action = "find_files";
options.desc = "Find project files";
};
"<leader>f" = {
action = "live_grep";
options.desc = "Livegrep";
};
};
};
# Startup dashboard
plugins.alpha = {
enable = true;
theme = "dashboard";
};
# "Smooth" scrolling
plugins.neoscroll = {
enable = true;
};
plugins.treesitter = {
enable = true;
};
plugins.noice.enable = true;
# File tree
plugins.chadtree = {
enable = true;
};
}