This repository has been archived on 2024-09-05. You can view files and clone it, but cannot push or open issues or pull requests.
server/flake.nix
2005 e55f1e1bbe
All checks were successful
build and publish docker image / deploy / build (push) Successful in 1m45s
flake.nix: removed packages because actions is now used to deployment
2024-06-01 19:20:06 +02:00

26 lines
493 B
Nix

{
description = "Developer shell for lp";
inputs = {
nixpkgs.url = "nixpkgs/nixos-unstable";
};
outputs = { self, nixpkgs, ... }:
let
# TODO add more systems
system = "x86_64-linux";
pkgs = import nixpkgs { inherit system; };
in
rec {
devShells."${system}".default = pkgs.mkShell {
buildInputs = with pkgs; [
maven
jdk22
jre8
# top run actions locally
act
];
};
};
}