This repository has been archived on 2024-09-05. You can view files and clone it, but cannot push or open issues or pull requests.
web-client/flake.nix
2005 0dd323a218 🔧 building process:
new dockerfile
added latest for actions on push to master
2024-06-12 08:37:21 +02:00

32 lines
658 B
Nix

{
inputs = {
# nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
systems.url = "github:nix-systems/default";
};
outputs =
{ systems
, nixpkgs
, ...
} @ inputs:
let
eachSystem = f:
nixpkgs.lib.genAttrs (import systems) (
system:
f nixpkgs.legacyPackages.${system}
);
in
{
devShells = eachSystem (pkgs: {
default = pkgs.mkShell {
buildInputs = [
pkgs.nodejs
pkgs.nodePackages.pnpm
pkgs.nodePackages.typescript
pkgs.nodePackages.typescript-language-server
];
};
});
};
}